Outils pour utilisateurs

Outils du site


envy

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

envy [19/04/2009 15:57] (Version actuelle)
Ligne 1: Ligne 1:
 +{{tag>​linux cartes_graphiques drivers}}
 +====== Utiliser le script Envy pour installer vos drivers vidéos ======
  
 +<​note>​Les problèmes de drivers graphiques ont été un gros problème avec Linux et le sont encore pour des distributions très basique. Pour ce qui est d'​Ubuntu,​ depuis la version 7.10 environ, de grands progrès ont été réalisés. Depuis cette version, j'ai de plus en plus de mal à trouver une carte graphique qui n'est pas supporté par le système d'​exploitation,​ que ce soit pour nVidia, ATI, mais également des cartes Intel intégrée à la carte mère.</​note>​
 +
 +Les drivers vidéos sous Linux sont vraiment pas facile à installer. Entre ceux dans les paquets, ceux à compiler et les problèmes à chaque changement de kernel, on ne s'en sort plus.
 +
 +Du coup, une personne vraiment géniale, et j'en profite pour la remercier de tout mon coeur, a inventé [[http://​www.albertomilone.com/​nvidia_scripts1.html|Envy]].
 +
 +Un script qui va trouver tout seul comme un grand les drivers les plus adaptés à votre carte graphique. Cependant, tout n'est pas encore rose... Envy n'est pas encore dans les paquets Ubuntu et du coup il faut l'​installer à la main. Mais pas de panique, l'​auteur a fait un très pratique .deb et l'​installation se déroule sans gros problème.
 +
 +Comme le site l'​explique vous téléchargez le fichier .deb en bas de la page en fonction de votre distribution,​ ensuite vous installez le paquet avec un dpkg -i le_fichier_.deb,​ et si il y a des problèmes de dépendance,​ lancez un sudo apt-get install -f de façon à forcer l'​installation des paquets dépendant. Si cela ne résout pas le problème, les paquets manquants sont marqués dans le rapport de dpkg, il vous suffit de les installer proprement.
 +
 +Et pour vraiment ne plus avoir aucun problème de dépendance,​ voici la ligne qui permet d'​installer tous les paquets dont envy dépends :
 +
 +<​code>​
 +sudo apt-get install build-essential debconf debhelper dh-make dpkg-dev fakeroot gcc gksu libstdc++5 module-assistant pkg-config python python-glade2 python-gtk2 python-vte xserver-xorg-dev
 +</​code>​
envy.txt · Dernière modification: 19/04/2009 15:57 (modification externe)